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ME 433   

CAE LAB 

Instruction                                                                                                3 Periods per week 

Duration of University Examination                                                     3 Hours  

University Examination                                                                  50 Marks  

Sessional                                                                                                  25 Marks 

 

1. Analysis of Plane Truss & Spatial Truss with various cross sections and materials 

to determine member forces, member strains & stresses, joint deflections under 

static, thermal and combined loading. 

2. 2D & 3D beam analysis with different sections, different materials for different 

loads (forces and moments) with different end supports. 

3. Static analysis of plate with a hole to determine the deformations, the Stresses to 

study the failure behavior and SCF. 

4. Plane stress, plane strain and axisymmetric loading on the in plane members with in 

plane loading to study the stresses and strains. 

5. Static analysis of connecting rod with tetrahedron and brick elements. 

6. Static Analysis of flat and curved shell due to internal pressure and moments to 

estimate the  strains,  stresses  and  reactions  forces  and  moments  with  different  

boundary conditions. 

7. Buckling analysis of plates, shells and beams to estimate BF and modes. 

8. Modal analysis of beams, plates and shells for natural frequencies and mode shapes. 

9.  Harmonic analysis of a Shaft subjected to periodic force and transient analysis of 

plate subjected to stepped and ramped loading with varying time. 

10. Steady state heat transfer Analysis Cross section of chimney and transient heat 

transfer analysis of solidification of castings. 

11. Non linear analysis of cantilever beam with non-linear materials at tip moment and 

post buckling analysis of shells for critical loads. 

12. Coupled field analysis. 

13. Flow analysis of pipe with different fluids/gasses/air for velocity and pressure 

gradients. 

14. CFD analysis of aerofoil design. 

15. CFD analysis of ducts/impeller/fan. 

16. Use of MATLAB for finding B matrix, stiffness matrix and loading matrices of 

beam/in plane/solid elements and interfacing with CAE software’s 

Note:     1. Any of FEA software ANSYS/ABAQUS/NASTRAN/NISA/CAEFEM/ADINA 

may be used 

2. Any 12 experiments to be conducted 
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LIST OF EXPERIMENTS 

 

1. Analysis of Plane Truss & Spatial Truss with various cross sections and 

materials to determine member forces, member strains & stresses, joint 

deflections under static, thermal and combined loading. 

2. 2D & 3D beam analysis with different sections, different materials for 

different loads (forces and moments) with different end supports. 

3. Static analysis of plate with a hole to determine the deformations, the Stresses 

to study the failure behavior and SCF. 

4. Plane stress, plane strain and axisymmetric loading on the in plane members 

with in plane loading to study the stresses and strains. 

5. Static analysis of connecting rod with tetrahedron and brick elements. 

6. Static Analysis of flat and curved shell due to internal pressure and moments 

to estimate the  strains,  stresses  and  reactions  forces  and  moments  with  

different  boundary conditions. 

7. Buckling analysis of plates, shells and beams to estimate BF and modes. 

8. Modal analysis of beams, plates and shells for natural frequencies and mode 

shapes. 

9. Harmonic analysis of a Shaft subjected to periodic force and transient 

analysis of plate subjected to stepped and ramped loading with varying time. 

10. Steady state heat transfer Analysis Cross section of chimney and transient 

heat transfer analysis of solidification of castings. 

11. Non linear analysis of cantilever beam with non-linear materials at tip 

moment and post buckling analysis of shells for critical loads. 

12. CFD analysis of aerofoil design. 
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CONTENTS 

Ex. 

No. 

Title of the exercise 
PG. 

NO. 

1. Introduction to Computer Aided Engineering  

2. Analysis of Plane Truss  

3. 2D & 3D beam analysis  

4. Static analysis of plate with a hole  

5. Static analysis of connecting rod  

6. Buckling analysis of plates, shells and beams  

7. Modal analysis  

8. Harmonic analysis  

9 Steady state heat transfer Analysis  

10 CFD analysis of aerofoil design  
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INTRODUCTION  

(Computer Aided Engineering) 

This module aims to give students an introduction to CAE to enable them to tackle a range 

of problems using appropriate software. An introduction to some numerical techniques is 

provided, the use of software is developed and critical appraisal of results is emphasized.  

For stress, thermal and many other types of analysis, only the simplest of configurations can 

be solved by exact analytic methods. For the vast majority of engineering components some 

alternative method is needed and the usual approach involves a method of approximation 

requiring some numerical techniques to solve, which in turn requires the use of a digital 

computer. 

NUMERICAL TECHNIQUES 

Stress, vibration and thermal analysis. 

There are 3 main methods of numerical approximation: 

 Finite difference (FD) method  

 Finite element analysis (FEA)  

 Boundary element method (BEM) 

 

These methods all have some advantages and disadvantages. FEA is a variant of some 

classical approximation methods, whereas the FD method is an older procedure that has 

been used in one form or another almost since the inception of differential calculus. FEA 

was first adapted for stress analysis problem solving by Southwell. Ever since FEA were 

first used, there have been arguments about their relative merits versus the longer 

established FD method. 

FEA  

FEA involves mathematical approximations associated with the displacement function of a 

particular element and geometric approximations to the component shape. An advantage of 

FEA is that it can be used to analyze virtually any structural problem in a routine manner - 

hence non homogeneous material can be accommodated as the assembly of elements with 

different properties is straightforward. 

FD Method  

The FD method uses a finite difference approximation to the (partial) differential equations 

that describe the behavior of the system. A significant difficulty in solving the equations is 
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that with fine meshes, needed for adequate accuracy, there may be instability in determining 

the solution. Discontinuous interfaces, such as abrupt changes in material properties or 

geometry require special treatment. FD tends to be used more for Fluids problems than for 

Mechanics problems. 

BEM  

The BEM method reduces the dimensionality of the problem by 1, so the overall size of the 

computation the smaller than in FEA or FD, but the matrices produced are assymetric and 

densely packed and may require just as much computational effort to solve as when using 

FEA or FD. The method is particularly suited to problems with high stress gradients such as 

fracture mechanics. Boundaries that are nominally at 'infinity' may readily by handled 

whereas such boundaries increase the size of FEA and FD problems. The underlying 

mathematics is however more complex than the other two methods. 

ANSYS 

FINITE ELEMENT ANALYSIS 

Finite element analysis (FEA) is a computer simulation technique used in engineering 

analysis it uses a numerical technique called the finite element method (FEA). There are 

many finite element software packages, both free and proprietary development of the finite 

element method in structural mechanics is usually based on an energy principle such as the 

virtual work principle or the minimum total potential energy principle. 

 

In general, there are three phases in any computer-aided engineering task: 

 Pre-processing- Defining the finite element model and environmental factors to be 

applied to it. 

 Analysis solver- Solution of finite element model. 

 Post-processing of results using visualization tools. 

 

PRE-PROCESSING 

The first step in using FEA, pre-processing, is constructing a finite element model of the 

structure to be analyzed. The input of a topological description of he structure’s geometric 

features is required in most FEA packages. This can be in either 1D, 2D or 3D form, 

modeled by line, shape, or surface representation, respectively, although nowadays 3D 

models are predominantly used. The primary objective of the model is to realistically 

replicate the important parameters and features of the real model. The simplest mechanism 

to achieve modeling similarity in structural analysis is to utilize pre-existing digital 

blueprints, design files, CAD models, and/or data by importing that into an FEA 
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environment. Once the finite element geometric model has been created, a meshing 

procedure is used to define and break-up the model into small elements. In general, a finite 

element model is defined by a mesh network, which is made up of the geometric 

arrangement of elements and nodes. 

Nodes represent points at which features such as displacements are calculated. FEA 

packages use node numbers to serve as an identification tool in viewing solutions in 

structures such as deflections. Elements are bounded by sets of nodes, and define localized 

mass and stiffness properties of the model. Elements are also defined by mesh numbers, 
which allow references to be made to corresponding deflections or stresses at specific model 

locations. 

ANALYSIS (COMPUTATION OF SOLUTION) 

The next stage of FEA process is analysis. The FEM conducts a series of computational 

procedures involving applied forces, and the properties of the elements which produce a 

model solution. Such a structural analysis allows the determination of effects such as 

deformations, strains, and stresses which are caused by applied structural loads such as 

force, pressure and gravity. 

POST-PROCESSING (VISUALIZATION) 

These results can then be studied using visualization tools within the FEA environment to 

view and to fully identify implications of the analysis. Numerical and graphical tools allow 

the precise location of data such as stresses and deflections to be identified. 
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INTRODUCTION TO ANSYS 

Ansys is a general purpose finite element modeling package for numerically solving a wide 

variety of mechanical, electrical problems.  

These problems include:  

Static/Dynamic structural analysis (Both linear and nonlinear)  

1. Fluid analysis  

laminar flow  

 turbulent flow  

2. Acoustic analysis 

3. Electromagnetic analysis  

4. Model analysis  

5. Thermal analysis  

- conduction  

- convection  

- radiation  

6. Transient thermal analysis  

7. Buckling analysis  

8. Spectrum analysis  

9. Harmonic analysis  

Static analysis: In this type of problem we determine the elastic data deflections and 

stresses at critical points due to a system to external forces acting on structure nodal. 

Modal analysis: In this type of problem we determine the vibration characteristics.  

Harmonic analysis: We will determine the response of structure to harmonically time 

varying loads. 

Buckling analysis: We determine the buckling loa ds and also buckling shape. 

Thermal analysis: In this we determine low thermal stresses are there in given structure. 

Fluid analysis: In this we can see how a comprehensive got that fluid flows through a given 

number under given condition. 

Structural Static Analysis 

A static analysis calculates the effects of steady loading conditions on a structure, while 

ignoring inertia and damping effects, such as those caused by time-var ying loads. A static 

analysis can, however, include steady inertia loads (such as gravity and rotational velocity), 

and time-varying loads that can be approximated as static equivalent loads (such as the static 

equivalent wind and seismic loads commonly defined in many building codes). 

 

Static analysis determines the displacements, stresses, strains, and forces in structures or 

components caused by loads that do not induce significant inertia and damping effects. 

Steady loading and response conditions are assumed; that is, the loads and the structure's 

response are assumed to vary slowly with respect to time. 
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The types of loading that can be applied in a static analysis include: 

 Externally applied forces and pressures 

 Steady-state inertial forces (such as gravity or rotational velocity) 

 Imposed (nonzero) displacements 

 Temperatures (for thermal strain) 

 Fluences (for nuclear swelling) 

Modal Analysis 

Use modal analysis to determine the vibration characteristics (natural frequencies and mode 

shapes) of a structure or a machine component while it is being designed. It can also serve as 

a starting point for another, more detailed, dynamic analysis, such as a transient dynamic 

analysis, a harmonic response analysis, or a spectrum analysis. 

 

You use modal analysis to determine the natural frequencies and mode shapes of a structure. 

The 

Natural frequencies and mode shapes are important parameters in the design of a structure 

for dynamic loading conditions. They are also required if you want to do a spectrum analysis 

or a mode superposition harmonic or transient analysis. You can do modal analysis on a 

prestressed structure, such as a spinning turbine blade. Another useful feature is modal 

cyclic symmetry, which allows you to review the mode shapes of a cyclically symmetric 

structure by modeling just a sector of it. Modal analysis in the ANSYS family of products is 

a linear analysis. Any nonlinearity, such as plasticity and contact (gap) elements, are ignored 

even if they are defined. You can choose from several mode extractions methods: Block 

Lanczos, Supernode, PCG Lanczos, reduced, asymmetric, damped, and QR damped. 

 

The damped and QR damped methods allow you to include damping in the structure. The 

QR Damped method also allows for unsymmetrical damping and stiffness matrices.  

 

Harmonic Response Analysis 

 

Any sustained cyclic load will produce a sustained cyclic response (a harmonic response) in 

a Structural system. Harmonic response analysis gives you the ability to predict the 

sustained dynamic behavior of your structures, thus enabling you to verify whether or not 

your designs will successfully overcome resonance, fatigue, and other harmful effects of 

forced vibrations.  

 

Harmonic response analysis is a technique used to determine the steady-state response of a 

linear 

Structure to loads that vary sinusoidally (harmonically) with time. The idea is to calculate 

the structure's response at several frequencies and obtain a graph of some response quantity 

(usually displacements) versus frequency. 

 

"Peak" responses are then identified on the graph and stresses reviewed at those peak 

frequencies. This analysis technique calculates only the steady-state, forced vibrations of a 
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structure. The transient vibrations, which occur at the beginning of the excitation, are not 

accounted for in a harmonic response analysis. 

  
Buckling Analysis  

 

Buckling analysis is a technique used to determine buckling loads (critical loads at which a 

structure becomes unstable) and buckled mode shapes (the characteristic shape associated 

with a structure's buckled response).  

 

Two techniques are available in the ANSYS Multiphysics, ANSYS Mechanical, ANSYS 

Structural, and ANSYS Professional programs for predicting the buckling load and buckling 

mode shape of a structure: Nonlinear buckling analysis, and Eigenvalue (or linear) 

buckling analysis. Because the two methods can yield dramatically different results, it is 

necessary to first understand the differences between them.  

 

 Nonlinear buckling analysis is usually the more accurate approach and is therefore   

recommended for design or evaluation of actual structures. This technique employs a 

nonlinear static analysis with gradually increasing loads to seek the load level at which 

your structure becomes unstable.  

 

Using the nonlinear technique, your model can include features such as initial 

imperfections, plastic behavior, gaps, and large-deflection response. In addition, using 

deflection-controlled loading, you can even track the post-buckled performance of your 

structure (which can be useful in cases where the structure buckles into a stable 

configuration, such as "snap-through" buckling of a shallow dome).  

 

 Eigenvalue buckling analysis predicts the theoretical buckling strength (the bifurcation 

point) of an ideal linear elastic structure. This method corresponds to the textbook 

approach to elastic buckling analysis: for instance, an eigenvalue buckling analysis of a 

column will match the classical Euler solution.  

 

However, imperfections and nonlinearities prevent most real-world structures from 

achieving their theoretical elastic buckling strength. Thus, eigenvalue buckling analysis 

often yields unconservative results, and should generally not be used in actual day-to-

day engineering analyses. 
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1. Main Window 

  

Within the Main Window there are following 5 divisions:  

Utility Menu: The Utility Menu contains functions that are available throughout the 

ANSYS session, such as file controls, selections, graphic controls and parameters. 

Input line: The Input Line shows program prompt messages and allows you to type in 

commands directly.  

Toolbar: The Toolbar contains push buttons that execute commonly used ANSYS 

commands. More push buttons can be added if desired.  

Main Menu: The Main Menu contains the primary ANSYS functions, organized by 

preprocessor, solution, general postprocessor, design optimizer. It is from this menu that the 

vast majority of modeling commands are issued. This is where you will note the greatest 

change between previous versions of ANSYS and version 11.0. However, while the versions 

appear different, the menu structure has not changed. 

Graphics Window: The Graphic Window is where graphics are shown and graphical 

picking can be made. It is here where you will graphically view the model in its various 

stages of construction and the ensuing results from the analysis.  

Output Window: Output Window displays text output from the program, such as listing of 

data, etc. It is usually positioned behind the Graphics Window and can be put to the front if 

necessary. 
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                              D 

  

Steps involved in problem: 

Preprocessing: Defining the Problem  

1. Give a Title (such as 'Bridge Truss Tutorial').  

In the Utility menu bar select File > Change Title: 

 

The following window will appear: 

 

Enter the title and click 'OK'. This title will appear in the bottom left corner of the 'Graphics' 

Window once you begin. Note: to get the title to appear immediately, select Utility Menu > 

Plot > Replot. 

2. Enter Keypoints 

The overall geometry is defined in ANSYS using keypoints which specify various 

principal coordinates to define the body.  
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From the 'ANSYS Main Menu' select: 

Preprocessor > Modeling > Create > Keypoints > In Active CS 

 

The following window will then appear: 

 

To define the first keypoint which has the coordinates x = 0 and y = 0:  

Enter keypoint number 1 in the appropriate box, and enter the x, y coordinates: 0, 0 in their 

appropriate boxes (as shown above).  

Click 'Apply' to accept what you have typed.  
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Enter the remaining keypoints using the same method.  

Note: When entering the final data point, click on 'OK' to indicate that you are finished 

entering keypoints. If you first press 'Apply' and then 'OK' for the final keypoint, you will 

have defined it twice! If you did press 'Apply' for the final point, simply press 'Cancel' to 

close this dialog box.  

Units 

Note the units of measure (i.e. mm) were not specified. It is the responsibility of the user to 

ensure that a consistent set of units are used for the problem; thus making any conversions 

where necessary.  

Correcting Mistakes 

When defining keypoints, lines, areas, volumes, elements, constraints and loads you are 

bound to make mistakes. Fortunately these are easily corrected so that you don't need to 

begin from scratch every time an error is made! Every 'Create' menu for generating these 

various entities also has a corresponding 'Delete' menu for fixing things up.  

3. Form Lines 

The keypoints must now be connected. We will use the mouse to select the keypoints to 

form the lines.  

In the main menu select: Preprocessor > Modeling > Create > Lines > Lines > In Active 

Coordinates. The following window will then appear:  

Use the mouse to pick keypoint #1 (i.e. click on it). It will now be marked by a small yellow 

box.   

Now move the mouse toward keypoint #2. A line will now show on the screen joining these 

two points. Left click and a permanent line will appear.  

Connect the remaining keypoints using the same method.  

When you're done, click on 'OK' in the 'Lines in Active Coordinates window, minimize the 

'Lines' menu and the 'Create' menu. Your ANSYS Graphics window should look similar to 

the following: 
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FOR EXAMPLE: 
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Disappearing Lines 

Please note that any lines you have created may 'disappear' throughout your analysis. 

However, they have most likely NOT been deleted. If this occurs at any time from the 

Utility Menu select: Plot > Lines 

4. Define the Type of Element: 

It is now necessary to create elements. This is called 'meshing'. ANSYS first needs to know 

what kind of elements to use for our problem:  

 From the Preprocessor Menu, select: Element Type > Add/Edit/Delete. The following 

window will then appear. 

Click on the 'Add...' button. The following window will appear: 

 

For this example, we will use the 2D spar element as selected in the above figure.Select the 

element shown and click 'OK'. You should see 'Type 1 LINK1' in the 'Element Types' 

window. 

 

Click on 'Close' in the 'Element Types' dialog box. 

 

5. Define Geometric Properties 

 

We now need to specify geometric properties for our elements: 

 

 In the Preprocessor menu, select Real Constants > Add/Edit/Delete. 

 
Click Add... and select 'Type 1 LINK1' (actually it is already selected). Click on 'OK'. The 

following window will appear: 
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As shown in the window above, enter the cross-sectional area (4350mm):  

 Click on 'OK'.  

 'Set 1' now appears in the dialog box. Click on 'Close' in the 'Real Constants' window.  

6. Element Material Properties: 

You then need to specify material properties:  

In the 'Preprocessor' menu select Material Props > Material Models 
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Double click on Structural > Linear > Elastic > Isotropic 

We are going to give the properties of Steel. Enter the following field:  

EX = 200000 
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1. Define Analysis Type 

First you must tell ANSYS how you want it to solve this problem: 

  

From the Solution Menu, select Analysis Type > New Analysis.  

Ensure that 'Static' is selected; i.e. you are going to do a static analysis on the truss as 

opposed to a dynamic analysis, for example.  

 Click 'OK'.  

 

2. Apply Constraints 

It is necessary to apply constraints to the model otherwise the model is not tied down or 

grounded and a singular solution will result. In mechanical structures, these constraints will 

typically be fixed, pinned and roller-type connections. As shown above, the left end of the 

truss bridge is pinned while the right end has a roller connection.  

In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 

Keypoints 
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Select the left end of the bridge (Keypoint 1) by clicking on it in the Graphics Window and 

click on 'OK'  

 

This location is fixed which means that all translational and rotational degrees of freedom 

(DOFs) are constrained. Therefore, select 'All DOF' by clicking on it and click 'OK'. You 

will see some blue triangles in the graphics window indicating the displacement contraints.  

3. Apply Loads 

As shown in the diagram, there are four downward loads of 280kN, 210kN, 280kN, and 

360kN at keypoints 1, 3, 5, and 7 respectively. 

 Select Define Loads > Apply > Structural > Force/Moment > on Keypoints.  



19 
 

 

Select FY in the 'Direction of force/mm'. This indicate that we will be applying the load in 

the 'y' direction  

Enter a value of -280000 in the 'Force/moment value' box and click 'OK'. Note that we are 

using units of N here; this is consistent with the previous values input.  

The force will appear in the graphics window as a red arrow. Apply the remaining loads in 

the same manner. The applied loads and constraints should now appear as shown below 

 

4. Solving the System: 

We now tell ANSYS to find the solution:  

In the 'Solution' menu select Solve > Current LS. This indicates that we desire the solution 

under the current Load Step (LS). 
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The above windows will appear. Ensure that your solution options are the same as shown 

above and click 'OK'.  

Once the solution is done the following window will pop up. Click 'Close' and close the 

/STATUS Command Window. 

 

 

Deformation 

In the General Postproc menu, select Plot Results > Deformed Shape. The following 

window will appear.  

 

 

 

Select 'Def + undef edge' and click 'OK' to view both the deformed and the undeformed 

object. 
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You should obtain the following. 

 

 

The deflection can also be obtained as a list as shown below. General Postproc > List 

Results > Nodal Solution select 'DOF Solution' and 'ALL DOFs' from the lists in the 'List 

Nodal Solution' window and click 'OK'. This means that we want to see a listing of all 

degrees of freedom from the solution. 
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Axial Stress 

For line elements (ie links, beams, spars, and pipes) you will often need to use the Element 

Table to gain access to derived data (ie stresses, strains). For this example we should obtain 

axial stress The Element Table is different for each element, therefore, using the item 'LS,1'. 

From the General Postprocessor menu select Element Table > Define Table. Click on 'Add' 

 

Utility Menu > PlotCtrls> Style > Contours 
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BARS 

Start  Programs  Ansys  Run interactive  Ok 

 File  Clear & Start new  Do not read file  Ok 

 File  Change job name  Bar1  Ok 

 File  Change title  Structural Analysis  Ok 

 Preferences  Structural and h-method  Ok 

 Preprocessor  Real Constant  Add  Link1  Ok  Cross section area 

and initial strain  Ok 

 Preprocessor  Material Properties  Isotropic1 Ok  Young’s modulus 

and Poisson ratio  Ok 

 Preprocessor  Create  Key points  Inactive CS  Pick all  Ok 

 Preprocessor  Size controls  All lines/Picked lines  No of element 

division  Ok 

 Preprocessor  Mesh lines  Pick all  Ok 

 Plot controls  Numbering  Node numbers on  Ok 

 Solution  Apply  Displacement  On nodes  Select node  Ok 

 Solution  Apply  Force  On nodes  Ok 

                    Solution  Solve  Current LS  Ok 

 General postprocessor  Element table  Define table  Add  By sequence 

num  SMISC 1 2 3 4  Apply  NMISC 2 4 8 12  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC2 

SMISC8  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC6 

SMISC12  Ok 

 General postprocessor  Plot element table  Item to be plotted  NMISC1 

NMISC3  Ok 

 General postprocessor  Plot element table  Item to be plotted  NMISC2 

NMISC4  Ok 

 General postprocessor  List results  Nodal solution  All DOF  Ok 

 Standard tool bar  File  Save as save database to filename. jpeg  Ok 

 Standard tool bar  Exit  Quit-no save  Ok 
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TRUSSES 

 Start  Programs  Ansys  Run interactive  Ok 

 File  Clear & Start new  Do not read file  Ok 

 File  Change job name  truss1  Ok 

 File  Change title  Structural analysis  Ok 

 Preferences  Structural and h-method  Ok 

 Preprocessor  Real constants  Add  Link1  Ok  Cross-sectional area and 

initial strain  Ok 

 Preprocessor  Material properties  Isotropic1  Ok  Young’s modulus and 

Poisson ratio  Ok 

 Preprocessor  Create  Key points  Inactive CS  Give co-ordinate  Apply 

and for last point  Ok 

 Preprocessor  Create  Lines  Inactive CS  Pick all  Ok 

 Preprocessor  Size controls  All lines/Picked lines  No of element division  

Ok 

 Preprocessor  Mesh lines  Pick all  Ok 

 Plot Controls  Numbering  Node numbers on  Ok 

 Solution  Apply  Displacement  On Nodes  Select node  Ok 

 Solution  Apply  Force  On nodes  Ok 

 Solution  Solve  Current Ls  Ok 

 General postprocessor  Element table  Define Table  Add           By 

sequence num  SMISC 1 2 3 4  Apply  NMISC 2 4 8 12  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC2 

SMISC8  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC6 

SMISC12  Ok 

 General postprocessor  Plot element table  Item to be plotted  NMISC1 

NMISC3  Ok 

 General postprocessor  Plot element table  Item to be plotted  NMISC2 

NMISC4  Ok 
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 General postprocessor  List results  Nodal solution  All DOF  Ok 

 Standard tool bar  File  Save as save database to filename. jpeg  Ok 

 Standard tool bar  Exit  Quit-no save  Ok 

 

BEAMS 

 Start  Programs  Ansys  Run interactive  Ok 

 File  Clear & Start new  Do not read file  Ok 

 File  Change job name  truss1  Ok 

 File  Change title  Structural analysis  Ok 

 Preferences  Structural and h-method  Ok 

 Preprocessor  Real Constant  Add  Link1  Ok  

 Preprocessor  Material Properties  Isotropic1 Ok  Young’s modulus and 

Poisson ratio  Ok 

 Preprocessor  Create  Areas  Rectangle  By 2 corners  Width: Height:  

Ok 

 Preprocessor  Size controls  All lines/Picked lines  No of element division  

Ok 

 Preprocessor  Mesh lines  Pick all  Ok 

 Plot controls  Numbering  Node numbers on  Ok 

 Solution  Apply  Displacement  On nodes  Select node  Ok 

 Solution  Apply  Force  On nodes  Ok 

 Solution  Solve  Current LS  Ok 

 General postprocessor  Element table  Define table  Add  By sequence num 

 SMISC 1 2 3 4  Apply  NMISC 2 4 8 12  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC2 

SMISC8  Ok 

 General postprocessor  Plot element table  Item to be plotted  SMISC6 

SMISC12  Ok 

 General postprocessor  Plot element table  Item to be plotted  NMISC1 

NMISC3  Ok 
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 General postprocessor  Plot element table  Item to be plotted  NMISC2 

NMISC4  Ok 

 General postprocessor  List results  Nodal solution  All DOF  Ok 

 Standard tool bar  File  Save as save database to filename. jpeg  Ok 

 Standard tool bar  Exit  Quit-no save  Ok 

THERMAL 

 Start  Programs  Ansys  Run interactive  Ok 

 File  Clear & Start new  Do not read file  Ok 

 File  Change job name  truss1  Ok 

 File  Change title  Structural analysis  Ok 

 Preferences  Thermal and h-method  Ok 

  

 Preprocessor  Element type  Add  Solid  Thermal mass  Ok  

 Preprocessor  Material Properties  Thermal conductivity  Isotropic1 Ok  

Young’s modulus and Poisson ratio  Ok 

 Preprocessor  Create  Areas  Rectangle  By 2 corners  Width: Height:  

Ok 

 Preprocessor  Size controls  Manual size  Areas  All areas  Edge length 

 Ok 

 Preprocessor  Mesh  Areas  Mapped  3 or 4 sided  Select area  Ok 

 Plot controls  Numbering  Node numbers on  Ok 

 Solution  Apply  Thermal  Temperature  On nodes  Pick lines  Ok  

Temp:  Ok 

 Solution  Solve  Current LS  Ok 

 General postprocessor  Plot results  Contour Plot  Nodal solution  All DOF 

 Ok 

 General postprocessor  List results  Nodal solution  Thermal gradient vector 

sum  Ok 

 General postprocessor  List results  Nodal solution  Thermal flux  Thermal 

flux sum  Ok 
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 Standard tool bar  File  Save as save database to filename. jpeg  Ok 

 Standard tool bar  Exit  Quit-no save  Ok 
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EXERCISE-1 

Problem 1: Determine the nodal deflections, reaction forces, and stress for the truss system 

shown below 
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Solution 

    NODE      UX          UY          UZ          USUM   

       1   0.0000      0.0000      0.0000      0.0000     

       2   0.23570E-01 0.11785E-01  0.0000     0.26352E-01 

       3   0.0000      0.0000      0.0000      0.0000     

       4   0.16351    -0.17492      0.0000     0.23945     

 

 MAXIMUM ABSOLUTE VALUES 

 NODE          4           4           0           4 

 VALUE   0.16351    -0.17492      0.0000     0.23945     

 

  

  ***** POST1 ELEMENT TABLE LISTING *****                                       

  

    STAT    CURRENT     CURRENT  

    ELEM    LS1         LEPE1    

       1   707.11     0.35355E-03 

       2  -235.70    -0.11785E-03 

       3   745.36     0.37268E-03 

       4  -1490.7    -0.74536E-03 

 

 MINIMUM VALUES 

 ELEM          4           4 

 VALUE   -1490.7    -0.74536E-03 

 

 MAXIMUM VALUES 

 ELEM          3           3 

 VALUE    745.36     0.37268E-03 

 

  

  ***** POST1 TOTAL REACTION SOLUTION LISTING *****                             

  

  LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  

  THE FOLLOWING X,Y,Z SOLUTIONS ARE IN THE GLOBAL COORDINATE 

SYSTEM             

  

    NODE      FX          FY     

       1  -500.00     -500.00     

       3   500.00      1500.0     

 

 TOTAL VALUES 

 VALUE   0.11369E-12  1000.0     

 

    ELEM    SMIS1    

       1   707.11     
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       2  -235.70     

       3   745.36     

       4  -1490.7     

 

 MINIMUM VALUES 

 ELEM          4 

 VALUE   -1490.7         MAXIMUM VALUES      ELEM          3           VALUE    745.36     
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Problem 2: Determine the nodal deflections, reaction forces, and stress for the truss system 

shown below 
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Solution 

 

  THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL 

COORDINATE SYSTEM   

  

    NODE      UX          UY          UZ          USUM   

       1   0.0000      0.0000      0.0000      0.0000     

       2   0.0000      0.0000      0.0000      0.0000     

       3  0.42667E-01 0.13200      0.0000     0.13872     

       4   0.0000      0.0000      0.0000      0.0000     

 

 MAXIMUM ABSOLUTE VALUES 

 NODE          3           3           0           3 

 VALUE   0.42667E-01 0.13200      0.0000     0.13872     

 

  ***** POST1 ELEMENT TABLE LISTING *****                                       

  

    STAT    CURRENT     CURRENT     CURRENT  

    ELEM    LS1         LEPE1       SMIS1    

       1   0.0000      0.0000      0.0000     

       2   6400.0     0.32000E-03  41280.     

       3  -10667.    -0.53333E-03 -68800.     

       4   8533.3     0.42667E-03  55040.     

 

 MINIMUM VALUES 

 ELEM          3           3           3 

 VALUE   -10667.    -0.53333E-03 -68800.     

 

 MAXIMUM VALUES 

 ELEM          4           4           4 

 VALUE    8533.3     0.42667E-03  55040.     

 

 

  THE FOLLOWING X,Y,Z SOLUTIONS ARE IN THE GLOBAL COORDINATE 

SYSTEM             

  

    NODE      FX          FY          FZ     

       1   55040.      41280.     

       2              -41280.     

       4  -55040.      0.0000     

 

 TOTAL VALUES 

 VALUE  -0.72760E-11-0.29104E-10  0.0000     
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Problem 3: Determine the nodal deflections, reaction forces, and stress for the truss system 

shown below 
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Solution 

  ***** POST1 ELEMENT TABLE LISTING *****                                       

  

    STAT    CURRENT  

    ELEM    LEPE1    

       1  0.28274E-05 

       2  0.43277E-04 

       3 -0.69190E-04 

       4  0.18277E-04 

       5 -0.56981E-05 

       6  0.21577E-04 

       7 -0.14965E-04 

       8  0.24319E-04 

       9 -0.22975E-04 

      10  0.16308E-04 

 

 MINIMUM VALUES 

 ELEM          3 

 VALUE  -0.69190E-04 

 

 MAXIMUM VALUES 

 ELEM          2 
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 VALUE   0.43277E-04 

 

  ***** POST1 NODAL DEGREE OF FREEDOM LISTING *****                             

  

  LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  

  THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL 

COORDINATE SYSTEM   

  

    NODE      UX          UY          UZ          USUM   

       1   0.0000      0.0000      0.0000      0.0000     

       2  0.25446E-02-0.41229E-01  0.0000     0.41307E-01 

       3  0.41494E-01-0.53638E-01  0.0000     0.67814E-01 

       4  0.35869E-01-0.11591      0.0000     0.12133     

       5  0.19420E-01-0.46357E-01  0.0000     0.50260E-01 

       6   0.0000      0.0000      0.0000      0.0000     

 

 MAXIMUM ABSOLUTE VALUES 

 NODE          3           4           0           4 

 VALUE   0.41494E-01-0.11591      0.0000     0.12133     

 

  ***** POST1 TOTAL REACTION SOLUTION LISTING *****                             

  

  LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  

  THE FOLLOWING X,Y,Z SOLUTIONS ARE IN THE GLOBAL COORDINATE 

SYSTEM             

  

    NODE      FX          FY     

       1   10000.      19048.     

       6 -0.10000E+06  30952.     

 

 TOTAL VALUES 

 VALUE   -90000.      50000.     
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EXERCISE-2 

Problem 1: A distributed load of 1000 N/m (1 N/mm) will be applied to a 

solid steel beam with a rectangular cross section as shown in the figure below. 

The cross-section of the beam is 10mm x 10mm while the modulus of elasticity 

of the steel is 200GPa. 
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Solution 

***** POST1 NODAL DEGREE OF FREEDOM LISTING *****                             

  

  LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  

  THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL 

COORDINATE SYSTEM   

  

    NODE      UX          UY          UZ          USUM   

      38   0.0000    -0.19783E-01  0.0000     0.19783E-01 

      39   0.0000    -0.13268E-01  0.0000     0.13268E-01 

      40   0.0000    -0.66584E-02  0.0000     0.66584E-02 

      41   0.0000      0.0000      0.0000      0.0000     

 

 MAXIMUM ABSOLUTE VALUES 

 NODE          0          21           0          21 

 VALUE    0.0000    -0.83333E-01  0.0000     0.83333E-01 

 

 

 ***** POST1 NODAL DEGREE OF FREEDOM LISTING *****                             

  

  LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  

  THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL 

COORDINATE SYSTEM   

  

    NODE      ROTZ   

      38  0.64529E-03 

      39  0.65700E-03 

      40  0.66421E-03 

      41  0.66667E-03 

 

 MAXIMUM ABSOLUTE VALUES 

 NODE          1 

 VALUE  -0.66667E-03 
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Problem 2: A distributed load of 1000 N/m (1 N/mm) will be applied to a 

solid steel beam with a rectangular cross section as shown in the figure below. 

The cross-section of the beam is 10mm x 10mm while the modulus of elasticity 

of the steel is 200GPa. 

 



44 
 



45 
 

 

  



46 
 

Solution 

   MAXIMUM ABSOLUTE VALUES 

 NODE          4 

 VALUE  -0.61798  

 

MAXIMUM ABSOLUTE VALUES 

 NODE         15 

 VALUE    1.1851     

 

  MINIMUM VALUES 

 ELEM         22          10          22          10 

 VALUE   -7000.0    -0.13956E+07 -7000.0    -0.13376E+07 

 

 MAXIMUM VALUES 

 ELEM          6           3           6           2 

 VALUE    3129.5     0.35634E+06  3640.8     0.35634E+06 

 

 

 MINIMUM VALUES 

 ELEM         22          10          22          10 

 VALUE   -7000.0    -0.13956E+07 -7000.0    -0.13376E+07 

 

 MAXIMUM VALUES 

 ELEM          6           3           6           2 

 VALUE    3129.5     0.35634E+06  3640.8     0.35634E+06 
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EXERCISE-3  

Problem 1: A rectangular plate with two circular holes, subjected to a uniform tensile 

stress of  200N/cm2 as shown in figure. Thickness of plate is 0.5cm, E=2 x 107 N/cm2  

poissons ratio v=0.3.perform the static analysis and calculate the deformations.  
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Solution 

                

 MAXIMUM ABSOLUTE VALUES 

 NODE          2           2           0           2 

 VALUE  -0.84066E-04-0.15510E-03  0.0000     0.17642E-03 

 

  

MINIMUM VALUES 

 NODE        125         134         150         572         572 

 VALUE    0.0000     -55.062     -200.56      9.7952      8.4946     

 

 MAXIMUM VALUES 

 NODE        126         552           1         126         126 

 VALUE    661.98      113.43      0.0000      661.98      659.65     
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Problem 2: A long cylindrical pressure vessel of mean diameter d and wall thickness t 

has closed ends and is subjected to an internal pressure P. Determine the axial stress σy and 

the hoop stress σz in the vessel at the mid thickness of the wall. 
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Solution 

 
' 
LOAD STEP=     1  SUBSTEP=     1                                              
   TIME=    1.0000      LOAD CASE=   0                                          
  NODAL RESULTS ARE FOR MATERIAL   1                                            
  
  THE FOLLOWING X,Y,Z VALUES ARE IN GLOBAL COORDINATES                          
  
    NODE    SX          SY          SZ          SXY         SYZ         SXZ      
    1084 -0.35231     0.86158      2.0846     0.14558E-02  0.0000      0.0000     
    1085 -0.35234     0.86163      2.0841    -0.27677E-03  0.0000      0.0000     
    1086 -0.35194     0.86157      2.0848    -0.20478E-02  0.0000      0.0000     
    1087  0.58123     0.74798     0.54742    -0.16055      0.0000      0.0000     
 
 MINIMUM VALUES 
 NODE        193         290           5           6           1           1 
 VALUE   -2.2292     -1.8952     -1.7886     -2.7841      0.0000      0.0000     
 
 MAXIMUM VALUES 
 NODE          6           6         255           7           1           1 
 VALUE    3.4745      4.2738      2.7522      2.6033      0.0000      0.0000     
 
 
LOAD STEP=     1  SUBSTEP=     1                                              
   TIME=    1.0000      LOAD CASE=   0                                          
  NODAL RESULTS ARE FOR MATERIAL   1                                            
  
  THE FOLLOWING X,Y,Z VALUES ARE IN GLOBAL COORDINATES                          
  
    NODE    SX          SY          SZ          SXY         SYZ         SXZ      
    1084 -0.35231     0.86158      2.0846     0.14558E-02  0.0000      0.0000     
    1085 -0.35234     0.86163      2.0841    -0.27677E-03  0.0000      0.0000     
    1086 -0.35194     0.86157      2.0848    -0.20478E-02  0.0000      0.0000     
    1087  0.58123     0.74798     0.54742    -0.16055      0.0000      0.0000     
 
 MINIMUM VALUES 
 NODE        193         290           5           6           1           1 
 VALUE   -2.2292     -1.8952     -1.7886     -2.7841      0.0000      0.0000     
 
 MAXIMUM VALUES 
 NODE          6           6         255           7           1           1 
 VALUE    3.4745      4.2738      2.7522      2.6033      0.0000      0.0000     
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Problem 3: A long cylinder subjected to uniform internal pressure (plane strain 

condition). E=2.1 x 107  N/cm2, 1/m=0.3.calculate the max deflection and radial stresses 

induced in the pressure vessel 
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Solution 

 

  THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL 

COORDINATE SYSTEM   

  

 

 MAXIMUM ABSOLUTE VALUES 

 NODE         86          66           0          88 

 VALUE   0.45396E-02 0.45396E-02  0.0000     0.45398E-02 

 

 

MINIMUM VALUES 

 NODE         86          66          66         102           1           1 

 VALUE   -9956.7     -9956.7      1992.6     -13357.      0.0000      0.0000     

 

 MAXIMUM VALUES 

 NODE         66          86          84           1           1           1 

 VALUE    16599.      16599.      2005.1    -0.13221      0.0000      0.0000     

 

 

LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  NODAL RESULTS ARE FOR MATERIAL   1                                            

  

MINIMUM VALUES 
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 NODE         86          66          66         102           1           1 

 VALUE   -9956.7     -9956.7      1992.6     -13357.      0.0000      0.0000     

 

 MAXIMUM VALUES 

 NODE         66          86          84           1           1           1 

 VALUE    16599.      16599.      2005.1    -0.13221      0.0000      0.0000     

 

 

LOAD STEP=     1  SUBSTEP=     1                                              

   TIME=    1.0000      LOAD CASE=   0                                          

  NODAL RESULTS ARE FOR MATERIAL   1                                            

  

    NODE    S1          S2          S3          SINT        SEQV     

    1403   6983.0      2000.0     -316.31      7299.3      6460.5     

    1405   7003.8      2000.0     -337.07      7340.8      6495.7     

 

 MINIMUM VALUES 

 NODE          1          66          88           1           1 

 VALUE    6664.9      1992.6     -10037.      6663.1      5922.4     

 

 MAXIMUM VALUES 

 NODE         88          84           2          88          88 

 VALUE    16704.      2005.1      1.8681      26740.      23196.     
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EXERCISE-4 

Problem 1: Buckling analysis of open cylindrical shell. 
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Solution 

 

  *****  INDEX OF DATA SETS ON RESULTS FILE  ***** 

 

   SET   TIME/FREQ    LOAD STEP   SUBSTEP  CUMULATIVE 

     1 0.66591E+06         1         1         1 

                                                                             

 

     2 0.66591E+06         1         2         2 

                                                                             

 

     3 0.11254E+07         1         3         3 

                                                                             

 

     4 0.11254E+07         1         4         4 
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Problem 2: Harmonic Analysis of a rectangular plate 
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Solution 

 

  *****  INDEX OF DATA SETS ON RESULTS FILE  ***** 

 

   SET   TIME/FREQ    LOAD STEP   SUBSTEP  CUMULATIVE 

     1 0.66591E+06         1         1         1 

                                                                             

 

     2 0.66591E+06         1         2         2 

                                                                             

 

     3 0.11254E+07         1         3         3 

                                                                             

 

     4 0.11254E+07         1         4         4 
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EXERCISE-5 

Problem 1: Modal analysis of Beam 
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Solution 

 

  *****  INDEX OF DATA SETS ON RESULTS FILE  ***** 

 

   SET   TIME/FREQ    LOAD STEP   SUBSTEP  CUMULATIVE 

     1  8.3244             1         1         1 

     2  82.000             1         2         1 

     3  1416.7             1         3         1 
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Problem 2: Harmonic analysis of a Beam 
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